revert it to 2.3.6 for now