update for 2.3.3; don't need extra -lcrypt
authorPaul Mackerras <paulus@samba.org>
Wed, 4 Feb 1998 01:39:24 +0000 (01:39 +0000)
committerPaul Mackerras <paulus@samba.org>
Wed, 4 Feb 1998 01:39:24 +0000 (01:39 +0000)
pppd/Makefile.linux

index 36249a8e7b4faf8275a72e4aade013c15e6f3734..1bf7b1a85751b9e3b984a5329bb418f469f3e578 100644 (file)
@@ -1,6 +1,6 @@
 #
 # pppd makefile for Linux
-# $Id: Makefile.linux,v 1.22 1997/11/27 06:07:12 paulus Exp $
+# $Id: Makefile.linux,v 1.23 1998/02/04 01:39:24 paulus Exp $
 #
 
 # Default installation locations
@@ -27,13 +27,18 @@ endif
 # CC = gcc
 #
 COPTS = -O2 # -g
-VER = 2.3.2
+VER = 2.3.3
 LIBS =
 
 ifneq ($(wildcard /usr/lib/libcrypt*),)
 LIBS += -lcrypt
 endif
 
+# Uncomment the next 2 lines to include support for Microsoft's
+# MS-CHAP authentication protocol.
+#CHAPMS=y
+#USE_CRYPT=y
+
 # The INCLUDE_DIRS must include the standard headers before the local
 # ones. If you just had -I.. then the order would be reversed. So, use
 # the default location for include files first before the .. location.
@@ -59,7 +64,7 @@ endif
 
 ifdef HAS_SHADOW
 CFLAGS   += -DHAS_SHADOW
-LIBS     := -lshadow -lcrypt $(LIBS)
+LIBS     := -lshadow $(LIBS)
 endif
 
 # For "Pluggable Authentication Modules", see ftp.redhat.com:/pub/pam/.