work around se driver bug
[ppp.git] / osf1 / makevers
1 #!/bin/sh
2 #
3 # create constants to figure out which version of Digital UNIX
4 # (or DEC OSF/1) we're building ppp for
5 #
6 FULL_VERSION=`uname -r`
7 MAJOR_VERSION=`echo $FULL_VERSION | cut -d. -f1 | cut -dV -f2`
8 MINOR_VERSION=`echo $FULL_VERSION | cut -d. -f2`
9 REVISION=`uname -v`
10
11 cat >ppp_osf.h <<XYZZY
12 /* Definitions for the exact version of Digital UNIX
13  * (aka DEC OSF/1) we're building PPP for.
14  *
15  * This file is automatically generated.  DO NOT EDIT!
16  */
17
18 XYZZY
19
20 echo "#define FULL_VERSION \"$FULL_VERSION\"" >>ppp_osf.h
21 echo "#define MAJOR_VERSION $MAJOR_VERSION" >>ppp_osf.h
22 echo "#define MINOR_VERSION $MINOR_VERSION" >>ppp_osf.h
23 echo "#define REVISION $REVISION" >>ppp_osf.h