pass more stuff to sub-makes
[ppp.git] / README.sunos4
1 This file describes the installation process for ppp-2.3 on systems
2 running SunOS 4.1.x (or the equivalent).
3
4 The STREAMS modules in the sunos4 directory provide kernel support for
5 PPP on SunOS 4.1.x systems.  They have been tested under SunOS 4.1.3
6 on a SparcStation 1+.  They should work under earlier SunOS 4.1.x
7 systems, but no guarantees are given.
8
9 These modules are designed to be loaded into the running kernel using
10 the `modload' command.
11
12
13 Installation.
14 *************
15
16 1. Run the configure script and make the user-level programs and the
17 kernel modules.
18
19         ./configure
20         make
21
22 2. Install the pppd, pppstats and chat programs and the loadable
23 module object files (you need to be root to do this):
24
25         make install
26
27 By default, the programs and the loadable module object files go into
28 /usr/local/etc.  Doing `make install' also copies a script called
29 ppp.INSTALL into /dev, and makes ppp.LOAD, ppp.UNLOAD, ppp.MKDEV and
30 ppp.RMDEV links to it.
31
32 3. Load the ppp modules (you need to be root for this too):
33
34         /dev/ppp.LOAD
35
36 You will want to do this in your /etc/rc.local file once you have
37 everything installed.  I suggest you put something like the following
38 in /etc/rc.local (or /etc/loadable, if you have one):
39
40         if [ -f /dev/ppp.AUTOLOAD ]; then
41                 /dev/ppp.LOAD
42         fi
43
44 and then create a /dev/ppp.AUTOLOAD file with the command
45
46         touch /dev/ppp.AUTOLOAD
47
48 It is not advisable to unload the "if_ppp" module, because it creates
49 network interface units, and SunOS does not provide any way to destroy
50 network interfaces once created.  If you do unload it, the system will
51 probably crash at some later stage.
52
53 If you have previously had ppp-2.2 installed, you may have statements
54 in your /etc/rc.local to load the ppp module.  You will need to remove
55 those.  Having done this, you will need to reboot to remove the old
56 ppp module and load the new modules.