]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
test/parser: Add simple yaboot test
[petitboot] / test / parser / Makefile.am
index 2e97fbe208e81ba5fa107ced54b1c1f2698a31bb..eff3ece474ec5bba3aab029114f8dd8fc5efbf01 100644 (file)
@@ -24,7 +24,8 @@ AM_CPPFLAGS = \
 
 AM_CFLAGS = -O0 -ggdb -Wall -Wextra -Werror
 
-TESTS = test-null
+TESTS = test-null \
+       test-yaboot-single
 
 check_PROGRAMS = $(TESTS)
 check_LIBRARIES = $(test_libs)
@@ -37,7 +38,8 @@ libtest.o: $(libtest_o_OBJECTS)
        $(LD) -o $@ -r $^
 
 # objects under test
-parser_test_objs = $(top_srcdir)/discover/resource.c \
+parser_test_objs = $(top_srcdir)/discover/yaboot-parser.c \
+                  $(top_srcdir)/discover/resource.c \
                   $(top_srcdir)/discover/paths.c \
                   $(top_srcdir)/discover/device-handler.c \
                   $(top_srcdir)/discover/parser-conf.c