Fix obvious subscript-out-of-range error.
[ppp.git] / pppd / plugins / passprompt.c
index 768901718e884d6654265817ee9c3ced1e2118e7..1d885fcea53ba53fa732381ad69be3737def9ad5 100644 (file)
@@ -50,7 +50,7 @@ static int promptpass(char *user, char *passwd)
     }
     if (!kid) {
        /* we are the child, exec the program */
-       char *argv[4], fdstr[32];
+       char *argv[5], fdstr[32];
        sys_close();
        closelog();
        close(p[0]);