Remove references to the old CHAP code.
[ppp.git] / pppd / Makefile.sol2
index 2504f29341ca88fa4a2bac8e86aad6f68de8947d..25f5772c4fcb011f782372e6d14dafdde1fd3127 100644 (file)
@@ -1,16 +1,15 @@
 #
 # Makefile for pppd under Solaris 2.
-# $Id: Makefile.sol2,v 1.15 1999/09/30 19:55:52 masputra Exp $
+# $Id: Makefile.sol2,v 1.24 2003/11/27 21:25:25 paulus Exp $
 #
 
-include ../svr4/Makedefs
+include ../Makedefs.com
 
-COPTS  += -xO2 -xspace -W0,-Lt
 CFLAGS =  -I../include -DSVR4 -DSOL2 $(COPTS)
 LIBS   = -lsocket -lnsl
 
-OBJS   =  main.o magic.o fsm.o lcp.o ipcp.o upap.o chap.o md5.o \
-       ccp.o auth.o options.o demand.o utils.o sys-svr4.o
+OBJS   =  main.o magic.o fsm.o lcp.o ipcp.o upap.o chap-new.o eap.o md5.o \
+       tty.o ccp.o ecp.o auth.o options.o demand.o utils.o sys-solaris.o
 
 #
 # uncomment the following to enable plugins
@@ -18,6 +17,12 @@ OBJS =  main.o magic.o fsm.o lcp.o ipcp.o upap.o chap.o md5.o \
 CFLAGS += -DPLUGIN
 LIBS   += -ldl
 
+#
+# Solaris 8 and above accomodates /var/run, so uncomment the
+# following to place pppd process IDs on that location
+#
+#CFLAGS += -D_PATH_VARRUN='"/var/run/"'
+
 #
 # uncomment the following to enable IPv6
 #