add a few defs
[ppp.git] / pppd / Makefile.linux
index ebe703e0386e1a04ff8f0fa6ac317c392ceddea6..1d5e75e7e31b5672a909bbebb1aff3c1d67870ed 100644 (file)
@@ -1,6 +1,6 @@
 #
 # pppd makefile for Linux
-# $Id: Makefile.linux,v 1.16 1996/09/26 06:19:57 paulus Exp $
+# $Id: Makefile.linux,v 1.21 1997/07/14 03:52:08 paulus Exp $
 #
 
 # Default installation locations
@@ -8,10 +8,10 @@ BINDIR = /usr/sbin
 MANDIR = /usr/man
 
 PPPDSRCS = main.c magic.c fsm.c lcp.c ipcp.c upap.c chap.c md5.c ccp.c \
-          ipxcp.c auth.c options.c sys-linux.c md4.c chap_ms.c \
+          ipxcp.c auth.c options.c sys-linux.c md4.c chap_ms.c cbcp.c \
           demand.c
 HEADERS =  callout.h pathnames.h patchlevel.h chap.h md5.h chap_ms.h md4.h \
-          ipxcp.h
+          ipxcp.h cbcp.h
 MANPAGES = pppd.8
 PPPDOBJS = main.o magic.o fsm.o lcp.o ipcp.o upap.o chap.o md5.o ccp.o \
           auth.o options.o demand.o sys-linux.o ipxcp.o
@@ -27,8 +27,12 @@ endif
 # CC = gcc
 #
 COPTS = -O2 # -g
-VER = 2.3.0
-LIBS = -lc -lbsd
+VER = 2.3.1
+LIBS =
+
+ifneq ($(wildcard /usr/lib/libcrypt*),)
+LIBS += -lcrypt
+endif
 
 # The INCLUDE_DIRS must include the standard headers before the local
 # ones. If you just had -I.. then the order would be reversed. So, use
@@ -40,14 +44,34 @@ COMPILE_FLAGS= -D_linux_=1 -DHAVE_PATHS_H -DIPX_CHANGE
 
 CFLAGS= $(COPTS) $(COMPILE_FLAGS) $(INCLUDE_DIRS)
 
+ifdef CHAPMS
+CFLAGS   += -DCHAPMS=1
+ifndef USE_CRYPT
+LIBS     := -ldes $(LIBS)
+else
+CFLAGS   += -DUSE_CRYPT=1
+endif
+PPPDOBJS += md4.o chap_ms.o
+ifdef MSLANMAN
+CFLAGS   += -DMSLANMAN=1
+endif
+endif
+
 ifdef HAS_SHADOW
 CFLAGS   += -DHAS_SHADOW
-LIBS     += -lshadow
+LIBS     := -lshadow -lcrypt $(LIBS)
 endif
 
+# For "Pluggable Authentication Modules", see ftp.redhat.com:/pub/pam/.
 ifdef USE_PAM
 CFLAGS   += -DUSE_PAM
-LIBS     += -lpam -ldl
+LIBS     := -lpam -ldl $(LIBS)
+endif
+
+# Lock library binary for Linux is included in 'linux' subdirectory.
+ifdef LOCKLIB
+LIBS     := -llock $(LIBS)
+CFLAGS   += -DLOCKLIB=1
 endif
 
 install: pppd