]> git.ozlabs.org Git - ppp.git/blobdiff - pppd/Makefile.am
Changing USE_PAM to PPP_WITH_PAM for consistency.
[ppp.git] / pppd / Makefile.am
index a7d64cf089de78eb5bfad3f05d4154ea9cee6670..c3f512fbd4497467c4b0eb548bcbae2882541740 100644 (file)
@@ -127,8 +127,10 @@ if PPP_WITH_IPV6CP
 pppd_SOURCES += ipv6cp.c eui64.c
 endif
 
-if WITH_PAM
-pppd_LIBS += -lpam -ldl
+if PPP_WITH_PAM
+pppd_CPPFLAGS += $(PAM_CFLAGS)
+pppd_LIBS += $(PAM_LIBS) -ldl
+pppd_LDFLAGS += $(PAM_LDFLAGS)
 endif
 
 if PPP_WITH_EAPTLS