clock32_t is clock_t (long)
[ppp.git] / configure
index 8aac73308c06e45d0ce558ecdf789e5efaeb45d7..511f55b00b89419ba5b87b24bfe243db11a5655b 100755 (executable)
--- a/configure
+++ b/configure
@@ -1,11 +1,13 @@
 #!/bin/sh
-# $Id: configure,v 1.21 1999/09/21 20:35:18 masputra Exp $
+# $Id: configure,v 1.23 1999/11/15 01:56:26 paulus Exp $
 
 if [ -d /NextApps ]; then
   system="NeXTStep"
 else
   system=`uname -s`
   release=`uname -r`
+  machine=`uname -p`
+  arch=`uname -m`
 fi
 state="unknown"
 
@@ -21,15 +23,15 @@ case $system in
                state="late"; ksrc="netbsd-1.2";;
     esac;;
   SunOS)
-    machine=`uname -p`
     case $release in
       [0-3]*)  state="ancient";;
       4*)      state="known"; ksrc="sunos4"; makext="sunos4";;
       5.[1-6]*)        state="known"; ksrc="svr4"; makext="sol2";;
       5.[789]*)        state="known"; ksrc="svr4"; makext="sol2";
-                if [ "$machine" = sparc ]; then 
-                 lp64="y" 
-               fi;;
+              case $arch in
+               sun4u)  lp64='y';;
+               *)      ;;
+             esac;;
     esac;;
   ULTRIX)
     makext="ultrix";
@@ -86,7 +88,7 @@ fi
 case $state in
   neolithic) 
     echo "This is a newer release on an outdated OS ($system)."
-    echo " This software may  or may not work on this OS."
+    echo " This software may or may not work on this OS."
     echo " You may want to download an older version of PPP for this OS.";;
   ancient)
     echo "This is an old release of a supported OS ($system)."