]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
discover: Use lowercase hex chars for MAC-address-based conf requests
[petitboot] / test / parser / Makefile.am
index 8159bd677647ef9186323e521add3e2204764435..7940f9d96a501dbcee54d1efdc34b8915753d325 100644 (file)
@@ -32,10 +32,18 @@ TESTS = \
        test-grub2-default-index \
        test-grub2-default-multiword \
        test-grub2-multiple-resolve \
+       test-grub2-multiple-id \
        test-grub2-single-line-if \
+       test-grub2-load-env \
+       test-grub2-save-env \
+       test-grub2-saved-default \
+       test-grub2-nondefault-prefix \
        test-grub2-f18-ppc64 \
        test-grub2-ubuntu-13_04-x86 \
+       test-grub2-lexer-error \
+       test-grub2-parser-error \
        test-kboot-single \
+       test-yaboot-empty \
        test-yaboot-single \
        test-yaboot-partition \
        test-yaboot-partition-override \
@@ -43,12 +51,22 @@ TESTS = \
        test-yaboot-root-global \
        test-yaboot-root-override \
        test-yaboot-device-override \
+       test-yaboot-global-state \
+       test-yaboot-leftovers \
        test-yaboot-default \
        test-yaboot-rh8-ppc64 \
        test-pxe-empty \
        test-pxe-single \
        test-pxe-initrd-in-append \
-       test-pxe-default
+       test-pxe-mac-without-conf \
+       test-pxe-ip-without-conf \
+       test-pxe-non-url-conf \
+       test-pxe-local \
+       test-pxe-pathprefix-with-conf \
+       test-pxe-non-url-pathprefix-with-conf \
+       test-pxe-pathprefix-discover \
+       test-pxe-pathprefix-discover-mac \
+       test-unresolved-remove
 
 $(TESTS): %: %.embedded-config.o
 $(TESTS): LDADD += $@.embedded-config.o
@@ -66,7 +84,9 @@ parser_objs = \
        $(top_srcdir)/discover/resource.c \
        $(top_srcdir)/discover/paths.c \
        $(top_srcdir)/discover/device-handler.c \
-       $(top_srcdir)/discover/parser-conf.c
+       $(top_srcdir)/discover/parser-conf.c \
+       $(top_srcdir)/discover/user-event.c \
+       $(top_srcdir)/discover/event.c
 
 libtest_ro_SOURCES = \
        main.c \