]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
discover/grub2: handle search commands to specify root filesystems
[petitboot] / test / parser / Makefile.am
index eff3ece474ec5bba3aab029114f8dd8fc5efbf01..f711c1e7fab8560c472527b0327ba5df332a6228 100644 (file)
@@ -25,11 +25,17 @@ AM_CPPFLAGS = \
 AM_CFLAGS = -O0 -ggdb -Wall -Wextra -Werror
 
 TESTS = test-null \
-       test-yaboot-single
+       test-grub2-single \
+       test-grub2-f18-ppc64 \
+       test-kboot-single \
+       test-yaboot-single \
+       test-yaboot-external \
+       test-yaboot-rh8-ppc64
 
 check_PROGRAMS = $(TESTS)
 check_LIBRARIES = $(test_libs)
-check_DATA =
+check_DATA = data/grub2-f18-ppc64.conf \
+            data/yaboot-rh8-ppc64.conf
 
 common_libs = $(top_builddir)/lib/libpbcore.la
 test_libs = libtest.o
@@ -39,6 +45,8 @@ libtest.o: $(libtest_o_OBJECTS)
 
 # objects under test
 parser_test_objs = $(top_srcdir)/discover/yaboot-parser.c \
+                  $(top_srcdir)/discover/kboot-parser.c \
+                  $(top_srcdir)/discover/grub2-parser.c \
                   $(top_srcdir)/discover/resource.c \
                   $(top_srcdir)/discover/paths.c \
                   $(top_srcdir)/discover/device-handler.c \