]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
discover/pxe: check for a valid boot option before adding
[petitboot] / test / parser / Makefile.am
index e5c32cface37179cf489e5313d72571ba197a559..e221bf2080c1918084ad92e59ec77badc980be5f 100644 (file)
@@ -23,7 +23,7 @@ AM_CPPFLAGS = \
 
 AM_CFLAGS = -O0 -ggdb -Wall -Wextra -Werror
 
 
 AM_CFLAGS = -O0 -ggdb -Wall -Wextra -Werror
 
-LDADD = $(top_builddir)/lib/libpbcore.la libtest.o
+LDADD = $(top_builddir)/lib/libpbcore.la libtest.ro
 
 TESTS = \
        test-null \
 
 TESTS = \
        test-null \
@@ -33,8 +33,17 @@ TESTS = \
        test-grub2-ubuntu-13_04-x86 \
        test-kboot-single \
        test-yaboot-single \
        test-grub2-ubuntu-13_04-x86 \
        test-kboot-single \
        test-yaboot-single \
+       test-yaboot-partition \
+       test-yaboot-partition-override \
        test-yaboot-external \
        test-yaboot-external \
-       test-yaboot-rh8-ppc64
+       test-yaboot-root-global \
+       test-yaboot-root-override \
+       test-yaboot-device-override \
+       test-yaboot-default \
+       test-yaboot-rh8-ppc64 \
+       test-pxe-empty \
+       test-pxe-single \
+       test-pxe-initrd-in-append
 
 $(TESTS): %: %.embedded-config.o
 $(TESTS): LDADD += $@.embedded-config.o
 
 $(TESTS): %: %.embedded-config.o
 $(TESTS): LDADD += $@.embedded-config.o
@@ -49,23 +58,23 @@ parser_objs = \
        $(top_srcdir)/discover/yaboot-parser.c \
        $(top_srcdir)/discover/kboot-parser.c \
        $(top_srcdir)/discover/grub2-parser.c \
        $(top_srcdir)/discover/yaboot-parser.c \
        $(top_srcdir)/discover/kboot-parser.c \
        $(top_srcdir)/discover/grub2-parser.c \
+       $(top_srcdir)/discover/pxe-parser.c \
        $(top_srcdir)/discover/resource.c \
        $(top_srcdir)/discover/paths.c \
        $(top_srcdir)/discover/device-handler.c \
        $(top_srcdir)/discover/parser-conf.c
 
        $(top_srcdir)/discover/resource.c \
        $(top_srcdir)/discover/paths.c \
        $(top_srcdir)/discover/device-handler.c \
        $(top_srcdir)/discover/parser-conf.c
 
-libtest_o_SOURCES = \
+libtest_ro_SOURCES = \
        main.c \
        utils.c \
        handler.c \
        parser-test.h \
        $(parser_objs)
 
        main.c \
        utils.c \
        handler.c \
        parser-test.h \
        $(parser_objs)
 
-libtest.o: $(libtest_o_OBJECTS)
+libtest.ro$(EXEEXT): $(libtest_ro_OBJECTS)
        $(LD) -o $@ -r $^
 
        $(LD) -o $@ -r $^
 
-check_PROGRAMS = $(TESTS)
-check_LIBRARIES = libtest.o
+check_PROGRAMS = $(TESTS) libtest.ro
 
 check_DATA = \
        data/grub2-f18-ppc64.conf \
 
 check_DATA = \
        data/grub2-f18-ppc64.conf \