]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
discover/pxe: check for a valid boot option before adding
[petitboot] / test / parser / Makefile.am
index c2d84a38a84009a0c92cfb7bf98144667cdb0d1f..e221bf2080c1918084ad92e59ec77badc980be5f 100644 (file)
@@ -33,8 +33,15 @@ TESTS = \
        test-grub2-ubuntu-13_04-x86 \
        test-kboot-single \
        test-yaboot-single \
+       test-yaboot-partition \
+       test-yaboot-partition-override \
        test-yaboot-external \
+       test-yaboot-root-global \
+       test-yaboot-root-override \
+       test-yaboot-device-override \
+       test-yaboot-default \
        test-yaboot-rh8-ppc64 \
+       test-pxe-empty \
        test-pxe-single \
        test-pxe-initrd-in-append
 
@@ -64,7 +71,7 @@ libtest_ro_SOURCES = \
        parser-test.h \
        $(parser_objs)
 
-libtest.ro: $(libtest_ro_OBJECTS)
+libtest.ro$(EXEEXT): $(libtest_ro_OBJECTS)
        $(LD) -o $@ -r $^
 
 check_PROGRAMS = $(TESTS) libtest.ro