]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
discover/yaboot: Fix assertion failure on empty yaboot files
[petitboot] / test / parser / Makefile.am
index 65dd7fcf491d13688e174229686f1efc67c073ec..abc95bbd98e6d2c4d39f00289f89c53572560564 100644 (file)
@@ -35,11 +35,14 @@ TESTS = \
        test-grub2-single-line-if \
        test-grub2-load-env \
        test-grub2-save-env \
+       test-grub2-saved-default \
+       test-grub2-nondefault-prefix \
        test-grub2-f18-ppc64 \
        test-grub2-ubuntu-13_04-x86 \
        test-grub2-lexer-error \
        test-grub2-parser-error \
        test-kboot-single \
+       test-yaboot-empty \
        test-yaboot-single \
        test-yaboot-partition \
        test-yaboot-partition-override \
@@ -52,7 +55,11 @@ TESTS = \
        test-pxe-empty \
        test-pxe-single \
        test-pxe-initrd-in-append \
-       test-pxe-default
+       test-pxe-mac-without-conf \
+       test-pxe-ip-without-conf \
+       test-pxe-non-url-conf \
+       test-pxe-local \
+       test-unresolved-remove
 
 $(TESTS): %: %.embedded-config.o
 $(TESTS): LDADD += $@.embedded-config.o
@@ -70,7 +77,9 @@ parser_objs = \
        $(top_srcdir)/discover/resource.c \
        $(top_srcdir)/discover/paths.c \
        $(top_srcdir)/discover/device-handler.c \
-       $(top_srcdir)/discover/parser-conf.c
+       $(top_srcdir)/discover/parser-conf.c \
+       $(top_srcdir)/discover/user-event.c \
+       $(top_srcdir)/discover/event.c
 
 libtest_ro_SOURCES = \
        main.c \