]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
discover/device-handler: Ensure we free unresolved boot options on remove
[petitboot] / test / parser / Makefile.am
index 8159bd677647ef9186323e521add3e2204764435..46f87cecdabd01d6f31b5d9ba26f06bf7241e57a 100644 (file)
@@ -33,8 +33,14 @@ TESTS = \
        test-grub2-default-multiword \
        test-grub2-multiple-resolve \
        test-grub2-single-line-if \
+       test-grub2-load-env \
+       test-grub2-save-env \
+       test-grub2-saved-default \
+       test-grub2-nondefault-prefix \
        test-grub2-f18-ppc64 \
        test-grub2-ubuntu-13_04-x86 \
+       test-grub2-lexer-error \
+       test-grub2-parser-error \
        test-kboot-single \
        test-yaboot-single \
        test-yaboot-partition \
@@ -48,7 +54,11 @@ TESTS = \
        test-pxe-empty \
        test-pxe-single \
        test-pxe-initrd-in-append \
-       test-pxe-default
+       test-pxe-mac-without-conf \
+       test-pxe-ip-without-conf \
+       test-pxe-non-url-conf \
+       test-pxe-local \
+       test-unresolved-remove
 
 $(TESTS): %: %.embedded-config.o
 $(TESTS): LDADD += $@.embedded-config.o
@@ -66,7 +76,9 @@ parser_objs = \
        $(top_srcdir)/discover/resource.c \
        $(top_srcdir)/discover/paths.c \
        $(top_srcdir)/discover/device-handler.c \
-       $(top_srcdir)/discover/parser-conf.c
+       $(top_srcdir)/discover/parser-conf.c \
+       $(top_srcdir)/discover/user-event.c \
+       $(top_srcdir)/discover/event.c
 
 libtest_ro_SOURCES = \
        main.c \