]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
discover/grub2: Hook up flex/bison parser to discover server
[petitboot] / test / parser / Makefile.am
index bb45a40f7939ea20d6b9ede35242eeb75eb425d9..1a5e43a1b5c3b53f607d405ccca42ab40448e236 100644 (file)
@@ -33,11 +33,18 @@ TESTS = \
        test-grub2-ubuntu-13_04-x86 \
        test-kboot-single \
        test-yaboot-single \
+       test-yaboot-partition \
+       test-yaboot-partition-override \
        test-yaboot-external \
        test-yaboot-root-global \
+       test-yaboot-root-override \
+       test-yaboot-device-override \
+       test-yaboot-default \
        test-yaboot-rh8-ppc64 \
+       test-pxe-empty \
        test-pxe-single \
-       test-pxe-initrd-in-append
+       test-pxe-initrd-in-append \
+       test-pxe-default
 
 $(TESTS): %: %.embedded-config.o
 $(TESTS): LDADD += $@.embedded-config.o
@@ -51,7 +58,6 @@ extract_config = $(srcdir)/extract-config.awk
 parser_objs = \
        $(top_srcdir)/discover/yaboot-parser.c \
        $(top_srcdir)/discover/kboot-parser.c \
-       $(top_srcdir)/discover/grub2-parser.c \
        $(top_srcdir)/discover/pxe-parser.c \
        $(top_srcdir)/discover/resource.c \
        $(top_srcdir)/discover/paths.c \
@@ -65,7 +71,10 @@ libtest_ro_SOURCES = \
        parser-test.h \
        $(parser_objs)
 
-libtest.ro$(EXEEXT): $(libtest_ro_OBJECTS)
+libtest_ro_LDADD = \
+       ../../discover/grub2/grub2-parser.ro
+
+libtest.ro$(EXEEXT): $(libtest_ro_OBJECTS) $(libtest_ro_LDADD)
        $(LD) -o $@ -r $^
 
 check_PROGRAMS = $(TESTS) libtest.ro