]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
test/parser: Add f18 grub config test
[petitboot] / test / parser / Makefile.am
index eff3ece474ec5bba3aab029114f8dd8fc5efbf01..10406706f6a2b097bfc276d1369b6e4bc9c3abe3 100644 (file)
@@ -25,11 +25,15 @@ AM_CPPFLAGS = \
 AM_CFLAGS = -O0 -ggdb -Wall -Wextra -Werror
 
 TESTS = test-null \
-       test-yaboot-single
+       test-grub2-single \
+       test-grub2-f18-ppc64 \
+       test-kboot-single \
+       test-yaboot-single \
+       test-yaboot-external
 
 check_PROGRAMS = $(TESTS)
 check_LIBRARIES = $(test_libs)
-check_DATA =
+check_DATA = data/grub2-f18-ppc64.conf
 
 common_libs = $(top_builddir)/lib/libpbcore.la
 test_libs = libtest.o
@@ -39,6 +43,8 @@ libtest.o: $(libtest_o_OBJECTS)
 
 # objects under test
 parser_test_objs = $(top_srcdir)/discover/yaboot-parser.c \
+                  $(top_srcdir)/discover/kboot-parser.c \
+                  $(top_srcdir)/discover/grub2-parser.c \
                   $(top_srcdir)/discover/resource.c \
                   $(top_srcdir)/discover/paths.c \
                   $(top_srcdir)/discover/device-handler.c \