]> git.ozlabs.org Git - petitboot/blobdiff - discover/Makefile.am
Add system info messages
[petitboot] / discover / Makefile.am
index 1dd63f1e088d76abf5b9681adeb922d51844abb5..1fd8d96c6001954c1620f6b5865e463146065b35 100644 (file)
@@ -14,6 +14,8 @@
 
 pkgsysconfdir = @sysconfdir@/@PACKAGE@
 
+SUBDIRS = grub2
+
 AM_CPPFLAGS = -I$(top_srcdir)/lib $(DEFAULT_CPPFLAGS)
 
 AM_CFLAGS = $(DEFAULT_CFLAGS)  \
@@ -51,6 +53,8 @@ pb_discover_SOURCES = \
        pb-discover.h \
        resource.c \
        resource.h \
+       sysinfo.c \
+       sysinfo.h \
        network.c \
        network.h \
        udev.c \
@@ -58,11 +62,10 @@ pb_discover_SOURCES = \
        user-event.c \
        user-event.h \
        kboot-parser.c \
-       grub2-parser.c \
        yaboot-parser.c \
        pxe-parser.c
 
-pb_discover_LDADD = $(top_builddir)/lib/libpbcore.la
+pb_discover_LDADD = $(top_builddir)/lib/libpbcore.la grub2/grub2-parser.ro
 
 pb_discover_LDFLAGS = -ludev