update for 2.3.3; changes so it will compile with glibc