]> git.ozlabs.org Git - petitboot/blobdiff - ui/ncurses/Makefile.am
ui/ncurses: Use a separate type for help text
[petitboot] / ui / ncurses / Makefile.am
index 3251489fbb335f018610b915ac57fb47df585590..be4c417d69e650e234b42c61ee507b6f14d34c91 100644 (file)
@@ -15,6 +15,7 @@
 AM_CPPFLAGS = \
        -I$(top_srcdir) \
        -I$(top_srcdir)/lib \
+       -DLOCALEDIR='"$(localedir)"' \
        $(DEFAULT_CPPFLAGS)
 
 AM_CFLAGS = \
@@ -31,10 +32,12 @@ noinst_LTLIBRARIES = libpbnc.la
 libpbnc_la_SOURCES = \
        nc-config.c \
        nc-config.h \
+       nc-config-help.c \
        nc-cui.c \
        nc-cui.h \
        nc-boot-editor.c \
        nc-boot-editor.h \
+       nc-boot-editor-help.c \
        nc-helpscreen.c \
        nc-helpscreen.h \
        nc-menu.c \
@@ -63,5 +66,6 @@ petitboot_ps3_nc_SOURCES = ps3-main.c
 petitboot_ps3_nc_LDADD = $(common_libs) $(libdir)/libps3-utils.so
 #petitboot_ps3_nc_LDFLAGS = -L$(libdir) -lps3-utils
 
+EXTRA_DIST = ui-guidelines.text
 
 MAINTAINERCLEANFILES = Makefile.in