]> git.ozlabs.org Git - petitboot/blobdiff - ui/ncurses/Makefile.am
ui/ncurses: Move menu initialisation to cui code
[petitboot] / ui / ncurses / Makefile.am
index ac4ca4643ce638f2ddee568784385f60258ebe38..39cf597eee2b36284af28ae48a7a713e036be092 100644 (file)
@@ -15,6 +15,7 @@
 AM_CPPFLAGS = \
        -I$(top_srcdir) \
        -I$(top_srcdir)/lib \
+       -DLOCALEDIR='"$(localedir)"' \
        $(DEFAULT_CPPFLAGS)
 
 AM_CFLAGS = \
@@ -29,16 +30,28 @@ common_libs = \
 noinst_LTLIBRARIES = libpbnc.la
 
 libpbnc_la_SOURCES = \
+       nc-config.c \
+       nc-config.h \
+       nc-config-help.c \
        nc-cui.c \
        nc-cui.h \
+       nc-cui-help.c \
        nc-boot-editor.c \
        nc-boot-editor.h \
+       nc-boot-editor-help.c \
+       nc-helpscreen.c \
+       nc-helpscreen.h \
        nc-menu.c \
        nc-menu.h \
        nc-scr.c \
        nc-scr.h \
        nc-sysinfo.c \
-       nc-sysinfo.h
+       nc-sysinfo.h \
+       nc-sysinfo-help.c \
+       nc-textscreen.c \
+       nc-textscreen.h \
+       nc-widgets.c \
+       nc-widgets.h
 
 sbin_PROGRAMS = petitboot-nc
 
@@ -54,5 +67,6 @@ petitboot_ps3_nc_SOURCES = ps3-main.c
 petitboot_ps3_nc_LDADD = $(common_libs) $(libdir)/libps3-utils.so
 #petitboot_ps3_nc_LDFLAGS = -L$(libdir) -lps3-utils
 
+EXTRA_DIST = ui-guidelines.text
 
 MAINTAINERCLEANFILES = Makefile.in