]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
discover/pxe: check for a valid boot option before adding
[petitboot] / test / parser / Makefile.am
index 5dba679f682bf39c582bdce98f349cad02adf871..e221bf2080c1918084ad92e59ec77badc980be5f 100644 (file)
@@ -33,8 +33,17 @@ TESTS = \
        test-grub2-ubuntu-13_04-x86 \
        test-kboot-single \
        test-yaboot-single \
+       test-yaboot-partition \
+       test-yaboot-partition-override \
        test-yaboot-external \
-       test-yaboot-rh8-ppc64
+       test-yaboot-root-global \
+       test-yaboot-root-override \
+       test-yaboot-device-override \
+       test-yaboot-default \
+       test-yaboot-rh8-ppc64 \
+       test-pxe-empty \
+       test-pxe-single \
+       test-pxe-initrd-in-append
 
 $(TESTS): %: %.embedded-config.o
 $(TESTS): LDADD += $@.embedded-config.o
@@ -49,6 +58,7 @@ parser_objs = \
        $(top_srcdir)/discover/yaboot-parser.c \
        $(top_srcdir)/discover/kboot-parser.c \
        $(top_srcdir)/discover/grub2-parser.c \
+       $(top_srcdir)/discover/pxe-parser.c \
        $(top_srcdir)/discover/resource.c \
        $(top_srcdir)/discover/paths.c \
        $(top_srcdir)/discover/device-handler.c \
@@ -61,7 +71,7 @@ libtest_ro_SOURCES = \
        parser-test.h \
        $(parser_objs)
 
-libtest.ro: $(libtest_ro_OBJECTS)
+libtest.ro$(EXEEXT): $(libtest_ro_OBJECTS)
        $(LD) -o $@ -r $^
 
 check_PROGRAMS = $(TESTS) libtest.ro