]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
test/parser: Add simple GRUB2 parser test
[petitboot] / test / parser / Makefile.am
index 3733039b6647c5ee64846da37e25c50facd7aaf1..cd8da4a80763f84388495ac3bdcfe0bd42e71355 100644 (file)
@@ -25,6 +25,7 @@ AM_CPPFLAGS = \
 AM_CFLAGS = -O0 -ggdb -Wall -Wextra -Werror
 
 TESTS = test-null \
 AM_CFLAGS = -O0 -ggdb -Wall -Wextra -Werror
 
 TESTS = test-null \
+       test-grub2-single \
        test-kboot-single \
        test-yaboot-single \
        test-yaboot-external
        test-kboot-single \
        test-yaboot-single \
        test-yaboot-external
@@ -42,6 +43,7 @@ libtest.o: $(libtest_o_OBJECTS)
 # objects under test
 parser_test_objs = $(top_srcdir)/discover/yaboot-parser.c \
                   $(top_srcdir)/discover/kboot-parser.c \
 # objects under test
 parser_test_objs = $(top_srcdir)/discover/yaboot-parser.c \
                   $(top_srcdir)/discover/kboot-parser.c \
+                  $(top_srcdir)/discover/grub2-parser.c \
                   $(top_srcdir)/discover/resource.c \
                   $(top_srcdir)/discover/paths.c \
                   $(top_srcdir)/discover/device-handler.c \
                   $(top_srcdir)/discover/resource.c \
                   $(top_srcdir)/discover/paths.c \
                   $(top_srcdir)/discover/device-handler.c \