]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
parser/yaboot: Fix check for image presence
[petitboot] / test / parser / Makefile.am
index c2d84a38a84009a0c92cfb7bf98144667cdb0d1f..bb45a40f7939ea20d6b9ede35242eeb75eb425d9 100644 (file)
@@ -34,6 +34,7 @@ TESTS = \
        test-kboot-single \
        test-yaboot-single \
        test-yaboot-external \
+       test-yaboot-root-global \
        test-yaboot-rh8-ppc64 \
        test-pxe-single \
        test-pxe-initrd-in-append
@@ -64,7 +65,7 @@ libtest_ro_SOURCES = \
        parser-test.h \
        $(parser_objs)
 
-libtest.ro: $(libtest_ro_OBJECTS)
+libtest.ro$(EXEEXT): $(libtest_ro_OBJECTS)
        $(LD) -o $@ -r $^
 
 check_PROGRAMS = $(TESTS) libtest.ro