]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
discover/grub2: Allow to separate the --id argument using a space char
[petitboot] / test / parser / Makefile.am
index 685d7acbbd1c6ad30e1134627f1b44fdba869cf1..748c8366c24c470d2260281c8246d3f985e911f0 100644 (file)
@@ -16,21 +16,40 @@ parser_TESTS = \
        test/parser/test-grub2-single \
        test/parser/test-grub2-default \
        test/parser/test-grub2-empty \
+       test/parser/test-grub2-noeol \
+       test/parser/test-grub2-menuentry-formats \
+       test/parser/test-grub2-if-formats \
+       test/parser/test-grub2-default-id \
+       test/parser/test-grub2-default-id-space \
        test/parser/test-grub2-default-index \
        test/parser/test-grub2-default-multiword \
+       test/parser/test-grub2-implicit-default-unset \
+       test/parser/test-grub2-implicit-default-invalid \
        test/parser/test-grub2-multiple-resolve \
        test/parser/test-grub2-multiple-id \
        test/parser/test-grub2-single-line-if \
+       test/parser/test-grub2-pos-param \
        test/parser/test-grub2-load-env \
        test/parser/test-grub2-save-env \
+       test/parser/test-grub2-save-env-dash-f \
        test/parser/test-grub2-saved-default \
        test/parser/test-grub2-nondefault-prefix \
        test/parser/test-grub2-f18-ppc64 \
        test/parser/test-grub2-f20-ppc64 \
        test/parser/test-grub2-ubuntu-13_04-x86 \
+       test/parser/test-grub2-sles-btrfs-snapshot \
        test/parser/test-grub2-lexer-error \
        test/parser/test-grub2-parser-error \
+       test/parser/test-grub2-test-file-ops \
+       test/parser/test-grub2-single-yocto \
+       test/parser/test-grub2-blscfg-default-filename \
+       test/parser/test-grub2-blscfg-default-index \
+       test/parser/test-grub2-blscfg-default-title \
+       test/parser/test-grub2-blscfg-multiple-bls \
+       test/parser/test-grub2-blscfg-opts-config \
+       test/parser/test-grub2-blscfg-opts-grubenv \
        test/parser/test-kboot-single \
+       test/parser/test-kboot-default \
        test/parser/test-yaboot-empty \
        test/parser/test-yaboot-single \
        test/parser/test-yaboot-partition \
@@ -48,12 +67,17 @@ parser_TESTS = \
        test/parser/test-pxe-initrd-in-append \
        test/parser/test-pxe-mac-without-conf \
        test/parser/test-pxe-ip-without-conf \
+       test/parser/test-pxe-ipxe \
+       test/parser/test-pxe-ipxe-named \
+       test/parser/test-pxe-ipxe-default \
        test/parser/test-pxe-non-url-conf \
        test/parser/test-pxe-local \
+       test/parser/test-pxe-ipappend \
        test/parser/test-pxe-pathprefix-with-conf \
        test/parser/test-pxe-non-url-pathprefix-with-conf \
        test/parser/test-pxe-pathprefix-discover \
        test/parser/test-pxe-pathprefix-discover-mac \
+       test/parser/test-pxe-pathprefix-port \
        test/parser/test-pxe-path-resolve-relative \
        test/parser/test-pxe-path-resolve-absolute \
        test/parser/test-pxe-discover-bootfile-root \
@@ -61,7 +85,17 @@ parser_TESTS = \
        test/parser/test-pxe-discover-bootfile-pathprefix \
        test/parser/test-pxe-discover-bootfile-relative-conffile \
        test/parser/test-pxe-discover-bootfile-absolute-conffile \
-       test/parser/test-unresolved-remove
+       test/parser/test-pxe-discover-bootfile-async-file \
+       test/parser/test-unresolved-remove \
+       test/parser/test-syslinux-single-yocto \
+       test/parser/test-syslinux-global-append \
+       test/parser/test-syslinux-explicit \
+       test/parser/test-syslinux-nested-config \
+       test/parser/test-native-globals \
+       test/parser/test-native-short \
+       test/parser/test-native-simple \
+       test/parser/test-native-strings
+
 
 TESTS += $(parser_TESTS)
 check_PROGRAMS += $(parser_TESTS) test/parser/libtest.ro
@@ -70,18 +104,22 @@ check_DATA += \
        test/parser/data/grub2-f18-ppc64.conf \
        test/parser/data/grub2-f20-ppc.conf \
        test/parser/data/grub2-ubuntu-13_04-x86.conf \
-       test/parser/data/yaboot-rh8-ppc64.conf
+       test/parser/data/yaboot-rh8-ppc64.conf \
+       test/parser/data/syslinux-include-root.cfg \
+       test/parser/data/syslinux-include-nest-1.cfg \
+       test/parser/data/syslinux-include-nest-2.cfg \
+       test/parser/data/native-short.conf
 
 $(parser_TESTS): AM_CPPFLAGS += \
                -I$(top_srcdir)/discover \
                -DLOCAL_STATE_DIR='"$(localstatedir)"'
 $(parser_TESTS): LDADD += $@.embedded-config.o test/parser/libtest.ro $(core_lib)
-$(parser_TESTS): %: %.embedded-config.o test/parser/libtest.ro
+$(parser_TESTS): %: %.embedded-config.o test/parser/libtest.ro $(core_lib)
 
 extract_config = $(srcdir)/test/parser/extract-config.awk
 
 %.embedded-config.c: %.c $(extract_config)
-       $(AWK) -f $(extract_config) $< > $@
+       $(AM_V_GEN)$(AWK) -f $(extract_config) $< > $@
 
 # objects under test
 
@@ -89,10 +127,13 @@ test_parser_libtest_ro_SOURCES = \
        test/parser/main.c \
        test/parser/utils.c \
        test/parser/handler.c \
+       test/parser/network.c \
+       test/parser/user-event.c \
        test/parser/parser-test.h \
        discover/yaboot-parser.c \
        discover/kboot-parser.c \
        discover/pxe-parser.c \
+       discover/syslinux-parser.c \
        discover/platform.c \
        discover/resource.c \
        discover/paths.c \
@@ -100,19 +141,23 @@ test_parser_libtest_ro_SOURCES = \
        discover/parser-conf.c \
        discover/user-event.c \
        discover/event.c \
-       $(discover_grub2_grub2_parser_ro_SOURCES)
+       $(discover_grub2_grub2_parser_ro_SOURCES) \
+       $(discover_native_native_parser_ro_SOURCES)
 
 test_parser_libtest_ro_CPPFLAGS = \
        $(AM_CPPFLAGS) \
        -I$(top_srcdir)/discover \
        -I$(top_srcdir)/discover/grub2 \
+       -I$(top_builddir)/discover/grub2 \
+       -I$(top_srcdir)/discover/native \
+       -I$(top_builddir)/discover/native \
        -DPETITBOOT_TEST \
        -DLOCAL_STATE_DIR='"$(localstatedir)"' \
        -DTEST_CONF_BASE='"$(top_srcdir)/test/parser/data"'
 
 test/parser/libtest.ro$(EXEEXT): $(test_parser_libtest_ro_OBJECTS) \
                                           $(test_parser_libtest_ro_LDADD)
-       $(LD) -o $@ -r $^
+       $(AM_V_GEN)$(LD) -o $@ -r $^
 
 EXTRA_DIST += $(check_DATA) $(extract_config)