]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
discover/yaboot: Allow all image options to be overridden by global options
[petitboot] / test / parser / Makefile.am
index c2d84a38a84009a0c92cfb7bf98144667cdb0d1f..4319705c576163aa48da7fef0b9d18ac1f850a1c 100644 (file)
@@ -34,6 +34,8 @@ TESTS = \
        test-kboot-single \
        test-yaboot-single \
        test-yaboot-external \
+       test-yaboot-root-global \
+       test-yaboot-root-override \
        test-yaboot-rh8-ppc64 \
        test-pxe-single \
        test-pxe-initrd-in-append
@@ -64,7 +66,7 @@ libtest_ro_SOURCES = \
        parser-test.h \
        $(parser_objs)
 
-libtest.ro: $(libtest_ro_OBJECTS)
+libtest.ro$(EXEEXT): $(libtest_ro_OBJECTS)
        $(LD) -o $@ -r $^
 
 check_PROGRAMS = $(TESTS) libtest.ro