]> git.ozlabs.org Git - petitboot/blobdiff - test/lib/Makefile.am
lib/process: Don't abort stdout reads on EINTR
[petitboot] / test / lib / Makefile.am
index 3b4d8cb4767d0428d77e378270027e8bb8af3c59..23bee364e727f3751e32a786492ac41fe8cdb744 100644 (file)
@@ -26,9 +26,14 @@ check_PROGRAMS = list-test \
        test-process-noargs \
        test-process-sync \
        test-process-sync-stdout \
        test-process-noargs \
        test-process-sync \
        test-process-sync-stdout \
+       test-process-stderr \
+       test-process-stderr-stdout \
        test-process-async \
        test-process-async-stdout \
        test-process-async \
        test-process-async-stdout \
-       test-process-both
+       test-process-parent-stdout \
+       test-process-both \
+       test-process-stdout-eintr \
+       test-fold
 
 TESTS = $(check_PROGRAMS)
 
 
 TESTS = $(check_PROGRAMS)