]> git.ozlabs.org Git - petitboot/blobdiff - lib/Makefile.am
ui/common: Add discover_client_enumerate to re-add device data
[petitboot] / lib / Makefile.am
index 7847d0968a48576da199a9ce8369faafcc8d83af..5fc8911bd3f8988afbfc3f3725603974898dec9c 100644 (file)
@@ -12,6 +12,8 @@
 #  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
 #
 
+AUTOMAKE_OPTIONS = subdir-objects
+
 AM_CPPFLAGS = -I$(top_srcdir)/lib $(DEFAULT_CPPFLAGS) \
        -DPREFIX='"$(prefix)"'
 
@@ -20,6 +22,8 @@ AM_CFLAGS = $(DEFAULT_CFLAGS)
 noinst_LTLIBRARIES = libpbcore.la
 
 libpbcore_la_SOURCES = \
+       fold/fold.h \
+       fold/fold.c \
        log/log.h \
        log/log.c \
        list/list.c \
@@ -28,10 +32,18 @@ libpbcore_la_SOURCES = \
        waiter/waiter.h \
        pb-protocol/pb-protocol.c \
        pb-protocol/pb-protocol.h \
+       pb-config/pb-config.c \
+       pb-config/pb-config.h \
+       process/process.c \
+       process/process.h \
        types/types.h \
        talloc/talloc.c \
        talloc/talloc.h \
        system/system.c \
-       system/system.h
+       system/system.h \
+       url/url.c \
+       url/url.h \
+       util/util.c \
+       util/util.h
 
 MAINTAINERCLEANFILES = Makefile.in