a74c914fd3acf84dbcaac360e6f5cabd3582f802
[ppp.git] / pppd / Makefile.linux
1 #
2 # pppd makefile for Linux
3 # $Id: Makefile.linux,v 1.70 2007/06/19 02:08:34 carlsonj Exp $
4 #
5
6 # Default installation locations
7 DESTDIR = $(INSTROOT)@DESTDIR@
8 BINDIR = $(DESTDIR)/sbin
9 MANDIR = $(DESTDIR)/share/man/man8
10 INCDIR = $(DESTDIR)/include
11
12 TARGETS = pppd
13
14 PPPDSRCS = main.c magic.c fsm.c lcp.c ipcp.c upap.c chap-new.c md5.c ccp.c \
15            ecp.c ipxcp.c auth.c options.c sys-linux.c md4.c chap_ms.c \
16            demand.c utils.c tty.c eap.c chap-md5.c session.c
17
18 HEADERS = ccp.h session.h chap-new.h ecp.h fsm.h ipcp.h \
19         ipxcp.h lcp.h magic.h md5.h patchlevel.h pathnames.h pppd.h \
20         upap.h eap.h
21
22 MANPAGES = pppd.8
23 PPPDOBJS = main.o magic.o fsm.o lcp.o ipcp.o upap.o chap-new.o md5.o ccp.o \
24            ecp.o auth.o options.o demand.o utils.o sys-linux.o ipxcp.o tty.o \
25            eap.o chap-md5.o session.o
26
27 #
28 # include dependencies if present
29 ifeq (.depend,$(wildcard .depend))
30 include .depend
31 endif
32
33 # CC = gcc
34 #
35 COPTS = -O2 -pipe -Wall -g
36 LIBS =
37
38 # Uncomment the next 2 lines to include support for Microsoft's
39 # MS-CHAP authentication protocol.  Also, edit plugins/radius/Makefile.linux.
40 CHAPMS=y
41 USE_CRYPT=y
42 # Don't use MSLANMAN unless you really know what you're doing.
43 #MSLANMAN=y
44 # Uncomment the next line to include support for MPPE.  CHAPMS (above) must
45 # also be enabled.  Also, edit plugins/radius/Makefile.linux.
46 MPPE=y
47
48 # Uncomment the next line to include support for PPP packet filtering.
49 # This requires that the libpcap library and headers be installed
50 # and that the kernel driver support PPP packet filtering.
51 FILTER=y
52
53 # Uncomment the next line to enable multilink PPP (enabled by default)
54 # Linux distributions: Please leave multilink ENABLED in your builds
55 # of pppd!
56 HAVE_MULTILINK=y
57
58 # Uncomment the next line to enable the TDB database (enabled by default.)
59 # If you enable multilink, then TDB is automatically enabled also.
60 # Linux distributions: Please leave TDB ENABLED in your builds.
61 USE_TDB=y
62
63 HAS_SHADOW=y
64 #USE_PAM=y
65 HAVE_INET6=y
66
67 # Enable plugins
68 PLUGIN=y
69
70 # Enable Microsoft proprietary Callback Control Protocol
71 #CBCP=y
72
73 # Enable EAP SRP-SHA1 authentication (requires libsrp)
74 #USE_SRP=y
75
76 # Use libutil
77 USE_LIBUTIL=y
78
79 MAXOCTETS=y
80
81 INCLUDE_DIRS= -I../include
82
83 COMPILE_FLAGS= -DHAVE_PATHS_H -DIPX_CHANGE -DHAVE_MMAP
84
85 CFLAGS= $(COPTS) $(COMPILE_FLAGS) $(INCLUDE_DIRS) '-DDESTDIR="@DESTDIR@"'
86
87 ifdef CHAPMS
88 CFLAGS   += -DCHAPMS=1
89 NEEDDES=y
90 PPPDOBJS += md4.o chap_ms.o
91 HEADERS += md4.h chap_ms.h
92 ifdef MSLANMAN
93 CFLAGS   += -DMSLANMAN=1
94 endif
95 ifdef MPPE
96 CFLAGS   += -DMPPE=1
97 endif
98 endif
99
100 # EAP SRP-SHA1
101 ifdef USE_SRP
102 CFLAGS  += -DUSE_SRP -DOPENSSL -I/usr/local/ssl/include
103 LIBS    += -lsrp -L/usr/local/ssl/lib -lcrypto
104 TARGETS += srp-entry
105 EXTRAINSTALL = $(INSTALL) -s -c -m 555 srp-entry $(BINDIR)/srp-entry
106 MANPAGES += srp-entry.8
107 EXTRACLEAN += srp-entry.o
108 NEEDDES=y
109 else
110 # OpenSSL has an integrated version of SHA-1, and its implementation
111 # is incompatible with this local SHA-1 implementation.  We must use
112 # one or the other, not both.
113 PPPDSRCS += sha1.c
114 HEADERS += sha1.h
115 PPPDOBJS += sha1.o
116 endif
117
118 ifdef HAS_SHADOW
119 CFLAGS   += -DHAS_SHADOW
120 #LIBS     += -lshadow $(LIBS)
121 endif
122
123 ifneq ($(wildcard /usr/include/crypt.h),)
124 CFLAGS  += -DHAVE_CRYPT_H=1
125 LIBS    += -lcrypt
126 endif
127
128 ifdef USE_LIBUTIL
129 CFLAGS  += -DHAVE_LOGWTMP=1
130 LIBS    += -lutil
131 endif
132
133 ifdef NEEDDES
134 ifndef USE_CRYPT
135 LIBS     += -ldes $(LIBS)
136 else
137 CFLAGS   += -DUSE_CRYPT=1
138 endif
139 PPPDOBJS += pppcrypt.o
140 HEADERS += pppcrypt.h
141 endif
142
143 # For "Pluggable Authentication Modules", see ftp.redhat.com:/pub/pam/.
144 ifdef USE_PAM
145 CFLAGS   += -DUSE_PAM
146 LIBS     += -lpam -ldl
147 endif
148
149 # Multi-linnk
150 ifdef HAVE_MULTILINK
151         # Multilink implies the use of TDB
152         USE_TDB=y
153
154         CFLAGS += -DHAVE_MULTILINK
155         PPPDSRCS += multilink.c
156         PPPDOBJS += multilink.o
157 endif
158
159 # TDB
160 ifdef USE_TDB
161         CFLAGS += -DUSE_TDB=1
162         PPPDSRCS += tdb.c spinlock.c
163         PPPDOBJS += tdb.o spinlock.o
164         HEADERS += tdb.h spinlock.h
165 endif
166
167 # Lock library binary for Linux is included in 'linux' subdirectory.
168 ifdef LOCKLIB
169 LIBS     += -llock
170 CFLAGS   += -DLOCKLIB=1
171 endif
172
173 ifdef PLUGIN
174 CFLAGS  += -DPLUGIN
175 LDFLAGS += -Wl,-E
176 LIBS    += -ldl
177 endif
178
179 ifdef FILTER
180 ifneq ($(wildcard /usr/include/pcap-bpf.h),)
181 LIBS    += -lpcap
182 CFLAGS  += -DPPP_FILTER
183 endif
184 endif
185
186 ifdef HAVE_INET6
187      PPPDSRCS += ipv6cp.c eui64.c
188      HEADERS  += ipv6cp.h eui64.h
189      PPPDOBJS += ipv6cp.o eui64.o
190      CFLAGS   += -DINET6=1
191 endif
192
193 ifdef CBCP
194      PPPDSRCS += cbcp.c
195      PPPDOBJS += cbcp.o
196      CFLAGS += -DCBCP_SUPPORT
197      HEADERS += cbcp.h
198 endif
199
200 ifdef MAXOCTETS
201      CFLAGS += -DMAXOCTETS
202 endif
203
204 INSTALL= install
205
206 all: $(TARGETS)
207
208 install: pppd
209         mkdir -p $(BINDIR) $(MANDIR)
210         $(EXTRAINSTALL)
211         $(INSTALL) -s -c -m 555 pppd $(BINDIR)/pppd
212         if chgrp pppusers $(BINDIR)/pppd 2>/dev/null; then \
213           chmod o-rx,u+s $(BINDIR)/pppd; fi
214         $(INSTALL) -c -m 444 pppd.8 $(MANDIR)
215
216 pppd: $(PPPDOBJS)
217         $(CC) $(CFLAGS) $(LDFLAGS) -o pppd $(PPPDOBJS) $(LIBS)
218
219 srp-entry:      srp-entry.c
220         $(CC) $(CFLAGS) $(LDFLAGS) -o $@ srp-entry.c $(LIBS)
221
222 install-devel:
223         mkdir -p $(INCDIR)/pppd
224         $(INSTALL) -c -m 644 $(HEADERS) $(INCDIR)/pppd
225
226 clean:
227         rm -f $(PPPDOBJS) $(EXTRACLEAN) $(TARGETS) *~ #* core
228
229 depend:
230         $(CPP) -M $(CFLAGS) $(PPPDSRCS) >.depend