]> git.ozlabs.org Git - petitboot/blobdiff - ui/ncurses/Makefile.am
ui/ncurses: Make Network: heading consistent with other labels
[petitboot] / ui / ncurses / Makefile.am
index 90b5cbf6f33314733c1ea0a184f59a1b08b2601f..ded3193f21e4ddb9614a503f2dd3abdefb8d5172 100644 (file)
 AM_CPPFLAGS = \
        -I$(top_srcdir) \
        -I$(top_srcdir)/lib \
-       -I$(includedir) \
        $(DEFAULT_CPPFLAGS)
 
 AM_CFLAGS = \
        $(DEFAULT_CFLAGS)
 
-AM_LDFLAGS = -lmenu -lform -lncurses
-
 common_libs = \
        libpbnc.la \
        $(top_builddir)/ui/common/libpbui.la \
-       $(top_builddir)/lib/libpbcore.la
+       $(top_builddir)/lib/libpbcore.la \
+       @MENU_LIB@ @FORM_LIB@ @CURSES_LIB@
 
 noinst_LTLIBRARIES = libpbnc.la
 
 libpbnc_la_SOURCES = \
+       nc-config.c \
+       nc-config.h \
+       nc-config-help.c \
        nc-cui.c \
        nc-cui.h \
-       nc-ked.c \
-       nc-ked.h \
+       nc-boot-editor.c \
+       nc-boot-editor.h \
+       nc-boot-editor-help.c \
+       nc-helpscreen.c \
+       nc-helpscreen.h \
        nc-menu.c \
        nc-menu.h \
        nc-scr.c \
-       nc-scr.h
+       nc-scr.h \
+       nc-sysinfo.c \
+       nc-sysinfo.h \
+       nc-sysinfo-help.c \
+       nc-textscreen.c \
+       nc-textscreen.h \
+       nc-widgets.c \
+       nc-widgets.h
 
 sbin_PROGRAMS = petitboot-nc
 
@@ -47,12 +58,13 @@ sbin_PROGRAMS += petitboot-ps3-nc
 endif
 
 
-petitboot_nc_SOURCES = generic-main.c
+petitboot_nc_SOURCES = generic-main.c generic-main-help.c
 petitboot_nc_LDADD = $(common_libs)
 
 petitboot_ps3_nc_SOURCES = ps3-main.c
 petitboot_ps3_nc_LDADD = $(common_libs) $(libdir)/libps3-utils.so
 #petitboot_ps3_nc_LDFLAGS = -L$(libdir) -lps3-utils
 
+EXTRA_DIST = ui-guidelines.text
 
 MAINTAINERCLEANFILES = Makefile.in