]> git.ozlabs.org Git - petitboot/blobdiff - ui/ncurses/Makefile.am
i18n: Mark translatable strings for ncurses UI
[petitboot] / ui / ncurses / Makefile.am
index 64b6eb1fd9215d2efeac97ffe458080cd9791f7b..be4c417d69e650e234b42c61ee507b6f14d34c91 100644 (file)
@@ -15,6 +15,7 @@
 AM_CPPFLAGS = \
        -I$(top_srcdir) \
        -I$(top_srcdir)/lib \
+       -DLOCALEDIR='"$(localedir)"' \
        $(DEFAULT_CPPFLAGS)
 
 AM_CFLAGS = \
@@ -29,14 +30,27 @@ common_libs = \
 noinst_LTLIBRARIES = libpbnc.la
 
 libpbnc_la_SOURCES = \
+       nc-config.c \
+       nc-config.h \
+       nc-config-help.c \
        nc-cui.c \
        nc-cui.h \
        nc-boot-editor.c \
        nc-boot-editor.h \
+       nc-boot-editor-help.c \
+       nc-helpscreen.c \
+       nc-helpscreen.h \
        nc-menu.c \
        nc-menu.h \
        nc-scr.c \
-       nc-scr.h
+       nc-scr.h \
+       nc-sysinfo.c \
+       nc-sysinfo.h \
+       nc-sysinfo-help.c \
+       nc-textscreen.c \
+       nc-textscreen.h \
+       nc-widgets.c \
+       nc-widgets.h
 
 sbin_PROGRAMS = petitboot-nc
 
@@ -45,12 +59,13 @@ sbin_PROGRAMS += petitboot-ps3-nc
 endif
 
 
-petitboot_nc_SOURCES = generic-main.c
+petitboot_nc_SOURCES = generic-main.c generic-main-help.c
 petitboot_nc_LDADD = $(common_libs)
 
 petitboot_ps3_nc_SOURCES = ps3-main.c
 petitboot_ps3_nc_LDADD = $(common_libs) $(libdir)/libps3-utils.so
 #petitboot_ps3_nc_LDFLAGS = -L$(libdir) -lps3-utils
 
+EXTRA_DIST = ui-guidelines.text
 
 MAINTAINERCLEANFILES = Makefile.in