]> git.ozlabs.org Git - petitboot/blobdiff - ui/ncurses/Makefile.am
ui/ncurses: Add support for 'add-url' action
[petitboot] / ui / ncurses / Makefile.am
index c03bdb7f9b42b0933fff75ebfb83a0ed061d6045..6112b655c206cfff595f3bbaa099a9f18b65e919 100644 (file)
@@ -15,6 +15,7 @@
 AM_CPPFLAGS = \
        -I$(top_srcdir) \
        -I$(top_srcdir)/lib \
+       -DLOCALEDIR='"$(localedir)"' \
        $(DEFAULT_CPPFLAGS)
 
 AM_CFLAGS = \
@@ -31,20 +32,31 @@ noinst_LTLIBRARIES = libpbnc.la
 libpbnc_la_SOURCES = \
        nc-config.c \
        nc-config.h \
+       nc-config-help.c \
        nc-cui.c \
        nc-cui.h \
+       nc-cui-help.c \
        nc-boot-editor.c \
        nc-boot-editor.h \
+       nc-boot-editor-help.c \
+       nc-helpscreen.c \
+       nc-helpscreen.h \
+       nc-lang.c \
+       nc-lang.h \
        nc-menu.c \
        nc-menu.h \
        nc-scr.c \
        nc-scr.h \
        nc-sysinfo.c \
        nc-sysinfo.h \
+       nc-sysinfo-help.c \
        nc-textscreen.c \
        nc-textscreen.h \
        nc-widgets.c \
-       nc-widgets.h
+       nc-widgets.h \
+       nc-add-url.c \
+       nc-add-url.h \
+       nc-add-url-help.c
 
 sbin_PROGRAMS = petitboot-nc
 
@@ -60,5 +72,6 @@ petitboot_ps3_nc_SOURCES = ps3-main.c
 petitboot_ps3_nc_LDADD = $(common_libs) $(libdir)/libps3-utils.so
 #petitboot_ps3_nc_LDFLAGS = -L$(libdir) -lps3-utils
 
+EXTRA_DIST = ui-guidelines.text
 
 MAINTAINERCLEANFILES = Makefile.in