]> git.ozlabs.org Git - petitboot/blobdiff - ui/ncurses/Makefile.am
ui/ncurses: Add support for 'add-url' action
[petitboot] / ui / ncurses / Makefile.am
index 877dc11b3e279bab64201d73b97cb9002a50b140..6112b655c206cfff595f3bbaa099a9f18b65e919 100644 (file)
@@ -15,6 +15,7 @@
 AM_CPPFLAGS = \
        -I$(top_srcdir) \
        -I$(top_srcdir)/lib \
+       -DLOCALEDIR='"$(localedir)"' \
        $(DEFAULT_CPPFLAGS)
 
 AM_CFLAGS = \
@@ -34,11 +35,14 @@ libpbnc_la_SOURCES = \
        nc-config-help.c \
        nc-cui.c \
        nc-cui.h \
+       nc-cui-help.c \
        nc-boot-editor.c \
        nc-boot-editor.h \
        nc-boot-editor-help.c \
        nc-helpscreen.c \
        nc-helpscreen.h \
+       nc-lang.c \
+       nc-lang.h \
        nc-menu.c \
        nc-menu.h \
        nc-scr.c \
@@ -49,7 +53,10 @@ libpbnc_la_SOURCES = \
        nc-textscreen.c \
        nc-textscreen.h \
        nc-widgets.c \
-       nc-widgets.h
+       nc-widgets.h \
+       nc-add-url.c \
+       nc-add-url.h \
+       nc-add-url-help.c
 
 sbin_PROGRAMS = petitboot-nc
 
@@ -58,12 +65,13 @@ sbin_PROGRAMS += petitboot-ps3-nc
 endif
 
 
-petitboot_nc_SOURCES = generic-main.c generic-main-help.c
+petitboot_nc_SOURCES = generic-main.c
 petitboot_nc_LDADD = $(common_libs)
 
 petitboot_ps3_nc_SOURCES = ps3-main.c
 petitboot_ps3_nc_LDADD = $(common_libs) $(libdir)/libps3-utils.so
 #petitboot_ps3_nc_LDFLAGS = -L$(libdir) -lps3-utils
 
+EXTRA_DIST = ui-guidelines.text
 
 MAINTAINERCLEANFILES = Makefile.in