]> git.ozlabs.org Git - petitboot/blobdiff - ui/ncurses/Makefile.am
ui/common: Add discover_client_enumerate to re-add device data
[petitboot] / ui / ncurses / Makefile.am
index 81602987b70139f471843e0e0d35a3e33b6c2c8c..39cf597eee2b36284af28ae48a7a713e036be092 100644 (file)
@@ -15,6 +15,7 @@
 AM_CPPFLAGS = \
        -I$(top_srcdir) \
        -I$(top_srcdir)/lib \
+       -DLOCALEDIR='"$(localedir)"' \
        $(DEFAULT_CPPFLAGS)
 
 AM_CFLAGS = \
@@ -31,10 +32,13 @@ noinst_LTLIBRARIES = libpbnc.la
 libpbnc_la_SOURCES = \
        nc-config.c \
        nc-config.h \
+       nc-config-help.c \
        nc-cui.c \
        nc-cui.h \
+       nc-cui-help.c \
        nc-boot-editor.c \
        nc-boot-editor.h \
+       nc-boot-editor-help.c \
        nc-helpscreen.c \
        nc-helpscreen.h \
        nc-menu.c \
@@ -43,6 +47,7 @@ libpbnc_la_SOURCES = \
        nc-scr.h \
        nc-sysinfo.c \
        nc-sysinfo.h \
+       nc-sysinfo-help.c \
        nc-textscreen.c \
        nc-textscreen.h \
        nc-widgets.c \
@@ -62,5 +67,6 @@ petitboot_ps3_nc_SOURCES = ps3-main.c
 petitboot_ps3_nc_LDADD = $(common_libs) $(libdir)/libps3-utils.so
 #petitboot_ps3_nc_LDFLAGS = -L$(libdir) -lps3-utils
 
+EXTRA_DIST = ui-guidelines.text
 
 MAINTAINERCLEANFILES = Makefile.in