]> git.ozlabs.org Git - petitboot/blobdiff - ui/ncurses/Makefile.am
ui/ncurses: Add help to system configuration screen
[petitboot] / ui / ncurses / Makefile.am
index a341780281b467cd04f2cbaee7483238c8863fc8..2834f12710a04c87618d61d83fe3da6df98ff17a 100644 (file)
@@ -29,16 +29,24 @@ common_libs = \
 noinst_LTLIBRARIES = libpbnc.la
 
 libpbnc_la_SOURCES = \
+       nc-config.c \
+       nc-config.h \
+       nc-config-help.c \
        nc-cui.c \
        nc-cui.h \
        nc-boot-editor.c \
        nc-boot-editor.h \
+       nc-helpscreen.c \
+       nc-helpscreen.h \
        nc-menu.c \
        nc-menu.h \
        nc-scr.c \
        nc-scr.h \
        nc-sysinfo.c \
        nc-sysinfo.h \
+       nc-sysinfo-help.c \
+       nc-textscreen.c \
+       nc-textscreen.h \
        nc-widgets.c \
        nc-widgets.h
 
@@ -49,7 +57,7 @@ sbin_PROGRAMS += petitboot-ps3-nc
 endif
 
 
-petitboot_nc_SOURCES = generic-main.c
+petitboot_nc_SOURCES = generic-main.c generic-main-help.c
 petitboot_nc_LDADD = $(common_libs)
 
 petitboot_ps3_nc_SOURCES = ps3-main.c