]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
discover: Support DHCP "pathprefix" configuration option
[petitboot] / test / parser / Makefile.am
index dbf626a42fed755e581db4efafe6f0d42b65e775..fdc53e30ee372154b43789cb5680f8781c761870 100644 (file)
@@ -32,14 +32,18 @@ TESTS = \
        test-grub2-default-index \
        test-grub2-default-multiword \
        test-grub2-multiple-resolve \
+       test-grub2-multiple-id \
        test-grub2-single-line-if \
        test-grub2-load-env \
        test-grub2-save-env \
+       test-grub2-saved-default \
+       test-grub2-nondefault-prefix \
        test-grub2-f18-ppc64 \
        test-grub2-ubuntu-13_04-x86 \
        test-grub2-lexer-error \
        test-grub2-parser-error \
        test-kboot-single \
+       test-yaboot-empty \
        test-yaboot-single \
        test-yaboot-partition \
        test-yaboot-partition-override \
@@ -47,6 +51,8 @@ TESTS = \
        test-yaboot-root-global \
        test-yaboot-root-override \
        test-yaboot-device-override \
+       test-yaboot-global-state \
+       test-yaboot-leftovers \
        test-yaboot-default \
        test-yaboot-rh8-ppc64 \
        test-pxe-empty \
@@ -55,7 +61,11 @@ TESTS = \
        test-pxe-mac-without-conf \
        test-pxe-ip-without-conf \
        test-pxe-non-url-conf \
-       test-pxe-local
+       test-pxe-local \
+       test-pxe-pathprefix-with-conf \
+       test-pxe-non-url-pathprefix-with-conf \
+       test-pxe-pathprefix-discover \
+       test-unresolved-remove
 
 $(TESTS): %: %.embedded-config.o
 $(TESTS): LDADD += $@.embedded-config.o