]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
discover: Handle and track plugin_options
[petitboot] / test / parser / Makefile.am
index d24e720f8c2f742b7291401240434f4f894e7b24..fa644fe3f98daa417cc49289e0eb0791965dd754 100644 (file)
@@ -16,20 +16,29 @@ parser_TESTS = \
        test/parser/test-grub2-single \
        test/parser/test-grub2-default \
        test/parser/test-grub2-empty \
+       test/parser/test-grub2-noeol \
+       test/parser/test-grub2-menuentry-formats \
+       test/parser/test-grub2-if-formats \
        test/parser/test-grub2-default-index \
        test/parser/test-grub2-default-multiword \
+       test/parser/test-grub2-implicit-default-unset \
+       test/parser/test-grub2-implicit-default-invalid \
        test/parser/test-grub2-multiple-resolve \
        test/parser/test-grub2-multiple-id \
        test/parser/test-grub2-single-line-if \
+       test/parser/test-grub2-pos-param \
        test/parser/test-grub2-load-env \
        test/parser/test-grub2-save-env \
+       test/parser/test-grub2-save-env-dash-f \
        test/parser/test-grub2-saved-default \
        test/parser/test-grub2-nondefault-prefix \
        test/parser/test-grub2-f18-ppc64 \
        test/parser/test-grub2-f20-ppc64 \
        test/parser/test-grub2-ubuntu-13_04-x86 \
+       test/parser/test-grub2-sles-btrfs-snapshot \
        test/parser/test-grub2-lexer-error \
        test/parser/test-grub2-parser-error \
+       test/parser/test-grub2-test-file-ops \
        test/parser/test-kboot-single \
        test/parser/test-yaboot-empty \
        test/parser/test-yaboot-single \
@@ -77,7 +86,7 @@ $(parser_TESTS): AM_CPPFLAGS += \
                -I$(top_srcdir)/discover \
                -DLOCAL_STATE_DIR='"$(localstatedir)"'
 $(parser_TESTS): LDADD += $@.embedded-config.o test/parser/libtest.ro $(core_lib)
-$(parser_TESTS): %: %.embedded-config.o test/parser/libtest.ro
+$(parser_TESTS): %: %.embedded-config.o test/parser/libtest.ro $(core_lib)
 
 extract_config = $(srcdir)/test/parser/extract-config.awk
 
@@ -90,6 +99,8 @@ test_parser_libtest_ro_SOURCES = \
        test/parser/main.c \
        test/parser/utils.c \
        test/parser/handler.c \
+       test/parser/network.c \
+       test/parser/user-event.c \
        test/parser/parser-test.h \
        discover/yaboot-parser.c \
        discover/kboot-parser.c \