]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
discover/grub2: Populate $prefix from config file location
[petitboot] / test / parser / Makefile.am
index fbf9c50af1a53058aca99d2761c983edfd50d580..f2ee67e00b1c0a0b45a64ac639014b8001f41d48 100644 (file)
@@ -28,10 +28,19 @@ LDADD = $(top_builddir)/lib/libpbcore.la libtest.ro
 TESTS = \
        test-null \
        test-grub2-single \
+       test-grub2-default \
+       test-grub2-default-index \
+       test-grub2-default-multiword \
        test-grub2-multiple-resolve \
        test-grub2-single-line-if \
+       test-grub2-load-env \
+       test-grub2-save-env \
+       test-grub2-saved-default \
+       test-grub2-nondefault-prefix \
        test-grub2-f18-ppc64 \
        test-grub2-ubuntu-13_04-x86 \
+       test-grub2-lexer-error \
+       test-grub2-parser-error \
        test-kboot-single \
        test-yaboot-single \
        test-yaboot-partition \
@@ -45,7 +54,10 @@ TESTS = \
        test-pxe-empty \
        test-pxe-single \
        test-pxe-initrd-in-append \
-       test-pxe-default
+       test-pxe-mac-without-conf \
+       test-pxe-ip-without-conf \
+       test-pxe-non-url-conf \
+       test-pxe-local
 
 $(TESTS): %: %.embedded-config.o
 $(TESTS): LDADD += $@.embedded-config.o
@@ -63,7 +75,9 @@ parser_objs = \
        $(top_srcdir)/discover/resource.c \
        $(top_srcdir)/discover/paths.c \
        $(top_srcdir)/discover/device-handler.c \
-       $(top_srcdir)/discover/parser-conf.c
+       $(top_srcdir)/discover/parser-conf.c \
+       $(top_srcdir)/discover/user-event.c \
+       $(top_srcdir)/discover/event.c
 
 libtest_ro_SOURCES = \
        main.c \