]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
autotools: Don't require custom automake options
[petitboot] / test / parser / Makefile.am
index aeb16d8adcab209b05d7f77bf30894f92d627ab7..f0eff9e37de4a5698ca9d9bdf668a7c6239852fb 100644 (file)
@@ -11,7 +11,7 @@
 #  along with this program; if not, write to the Free Software
 #  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
 
-AUTOMAKE_OPTIONS = parallel-tests
+AUTOMAKE_OPTIONS = parallel-tests foreign
 
 AM_CPPFLAGS = \
        -I$(top_srcdir) \
@@ -29,6 +29,7 @@ TESTS = \
        test-null \
        test-grub2-single \
        test-grub2-default \
+       test-grub2-empty \
        test-grub2-default-index \
        test-grub2-default-multiword \
        test-grub2-multiple-resolve \
@@ -67,6 +68,13 @@ TESTS = \
        test-pxe-non-url-pathprefix-with-conf \
        test-pxe-pathprefix-discover \
        test-pxe-pathprefix-discover-mac \
+       test-pxe-path-resolve-relative \
+       test-pxe-path-resolve-absolute \
+       test-pxe-discover-bootfile-root \
+       test-pxe-discover-bootfile-subdir \
+       test-pxe-discover-bootfile-pathprefix \
+       test-pxe-discover-bootfile-relative-conffile \
+       test-pxe-discover-bootfile-absolute-conffile \
        test-unresolved-remove
 
 $(TESTS): %: %.embedded-config.o