]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
test/parser: Add dependency on libpbcore.la
[petitboot] / test / parser / Makefile.am
index 685d7acbbd1c6ad30e1134627f1b44fdba869cf1..eca4c0a6df9ee61368aa19dcb3b6ae250b20d1dc 100644 (file)
@@ -50,6 +50,7 @@ parser_TESTS = \
        test/parser/test-pxe-ip-without-conf \
        test/parser/test-pxe-non-url-conf \
        test/parser/test-pxe-local \
+       test/parser/test-pxe-ipappend \
        test/parser/test-pxe-pathprefix-with-conf \
        test/parser/test-pxe-non-url-pathprefix-with-conf \
        test/parser/test-pxe-pathprefix-discover \
@@ -76,12 +77,12 @@ $(parser_TESTS): AM_CPPFLAGS += \
                -I$(top_srcdir)/discover \
                -DLOCAL_STATE_DIR='"$(localstatedir)"'
 $(parser_TESTS): LDADD += $@.embedded-config.o test/parser/libtest.ro $(core_lib)
-$(parser_TESTS): %: %.embedded-config.o test/parser/libtest.ro
+$(parser_TESTS): %: %.embedded-config.o test/parser/libtest.ro $(core_lib)
 
 extract_config = $(srcdir)/test/parser/extract-config.awk
 
 %.embedded-config.c: %.c $(extract_config)
-       $(AWK) -f $(extract_config) $< > $@
+       $(AM_V_GEN)$(AWK) -f $(extract_config) $< > $@
 
 # objects under test
 
@@ -106,13 +107,14 @@ test_parser_libtest_ro_CPPFLAGS = \
        $(AM_CPPFLAGS) \
        -I$(top_srcdir)/discover \
        -I$(top_srcdir)/discover/grub2 \
+       -I$(top_builddir)/discover/grub2 \
        -DPETITBOOT_TEST \
        -DLOCAL_STATE_DIR='"$(localstatedir)"' \
        -DTEST_CONF_BASE='"$(top_srcdir)/test/parser/data"'
 
 test/parser/libtest.ro$(EXEEXT): $(test_parser_libtest_ro_OBJECTS) \
                                           $(test_parser_libtest_ro_LDADD)
-       $(LD) -o $@ -r $^
+       $(AM_V_GEN)$(LD) -o $@ -r $^
 
 EXTRA_DIST += $(check_DATA) $(extract_config)