]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
discover/grub2: Fix behavior of save_env -f
[petitboot] / test / parser / Makefile.am
index 75411496526f2034874a50984fb9e60f3b7a2233..dddb4722109fb134caad769383d5167eef25dee5 100644 (file)
@@ -16,18 +16,25 @@ parser_TESTS = \
        test/parser/test-grub2-single \
        test/parser/test-grub2-default \
        test/parser/test-grub2-empty \
+       test/parser/test-grub2-noeol \
+       test/parser/test-grub2-menuentry-formats \
+       test/parser/test-grub2-if-formats \
        test/parser/test-grub2-default-index \
        test/parser/test-grub2-default-multiword \
+       test/parser/test-grub2-implicit-default-unset \
+       test/parser/test-grub2-implicit-default-invalid \
        test/parser/test-grub2-multiple-resolve \
        test/parser/test-grub2-multiple-id \
        test/parser/test-grub2-single-line-if \
        test/parser/test-grub2-load-env \
        test/parser/test-grub2-save-env \
+       test/parser/test-grub2-save-env-dash-f \
        test/parser/test-grub2-saved-default \
        test/parser/test-grub2-nondefault-prefix \
        test/parser/test-grub2-f18-ppc64 \
        test/parser/test-grub2-f20-ppc64 \
        test/parser/test-grub2-ubuntu-13_04-x86 \
+       test/parser/test-grub2-sles-btrfs-snapshot \
        test/parser/test-grub2-lexer-error \
        test/parser/test-grub2-parser-error \
        test/parser/test-kboot-single \
@@ -50,6 +57,7 @@ parser_TESTS = \
        test/parser/test-pxe-ip-without-conf \
        test/parser/test-pxe-non-url-conf \
        test/parser/test-pxe-local \
+       test/parser/test-pxe-ipappend \
        test/parser/test-pxe-pathprefix-with-conf \
        test/parser/test-pxe-non-url-pathprefix-with-conf \
        test/parser/test-pxe-pathprefix-discover \
@@ -76,7 +84,7 @@ $(parser_TESTS): AM_CPPFLAGS += \
                -I$(top_srcdir)/discover \
                -DLOCAL_STATE_DIR='"$(localstatedir)"'
 $(parser_TESTS): LDADD += $@.embedded-config.o test/parser/libtest.ro $(core_lib)
-$(parser_TESTS): %: %.embedded-config.o test/parser/libtest.ro
+$(parser_TESTS): %: %.embedded-config.o test/parser/libtest.ro $(core_lib)
 
 extract_config = $(srcdir)/test/parser/extract-config.awk
 
@@ -89,6 +97,7 @@ test_parser_libtest_ro_SOURCES = \
        test/parser/main.c \
        test/parser/utils.c \
        test/parser/handler.c \
+       test/parser/network.c \
        test/parser/parser-test.h \
        discover/yaboot-parser.c \
        discover/kboot-parser.c \
@@ -106,6 +115,7 @@ test_parser_libtest_ro_CPPFLAGS = \
        $(AM_CPPFLAGS) \
        -I$(top_srcdir)/discover \
        -I$(top_srcdir)/discover/grub2 \
+       -I$(top_builddir)/discover/grub2 \
        -DPETITBOOT_TEST \
        -DLOCAL_STATE_DIR='"$(localstatedir)"' \
        -DTEST_CONF_BASE='"$(top_srcdir)/test/parser/data"'