]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
autotools: Fix make maintainer-clean
[petitboot] / test / parser / Makefile.am
index d8135d4d4756fb82107ad744ed6c26a91118533a..b93bd31c1d42c3cf6ec3a3cecbeabf8197ee6fb1 100644 (file)
@@ -25,12 +25,20 @@ AM_CPPFLAGS = \
 AM_CFLAGS = -O0 -ggdb -Wall -Wextra -Werror
 
 TESTS = test-null \
+       test-grub2-single \
+       test-grub2-multiple-resolve \
+       test-grub2-f18-ppc64 \
+       test-grub2-ubuntu-13_04-x86 \
+       test-kboot-single \
        test-yaboot-single \
-       test-yaboot-external
+       test-yaboot-external \
+       test-yaboot-rh8-ppc64
 
 check_PROGRAMS = $(TESTS)
 check_LIBRARIES = $(test_libs)
-check_DATA =
+check_DATA = data/grub2-f18-ppc64.conf \
+            data/grub2-ubuntu-13_04-x86.conf \
+            data/yaboot-rh8-ppc64.conf
 
 common_libs = $(top_builddir)/lib/libpbcore.la
 test_libs = libtest.o
@@ -40,6 +48,8 @@ libtest.o: $(libtest_o_OBJECTS)
 
 # objects under test
 parser_test_objs = $(top_srcdir)/discover/yaboot-parser.c \
+                  $(top_srcdir)/discover/kboot-parser.c \
+                  $(top_srcdir)/discover/grub2-parser.c \
                   $(top_srcdir)/discover/resource.c \
                   $(top_srcdir)/discover/paths.c \
                   $(top_srcdir)/discover/device-handler.c \
@@ -56,9 +66,11 @@ $(check_PROGRAMS): LDADD += $@.embedded-config.o
 extract_config = $(srcdir)/extract-config.awk
 
 %.embedded-config.c: %.c $(extract_config)
-       gawk --file=$(extract_config) $^ > $@
+       $(AWK) -f $(extract_config) $< > $@
 
 EXTRA_DIST = $(check_DATA) $(extract_config)
 
 CLEANFILES = $(foreach f, $(check_PROGRAMS), \
                $(f).embedded-config.c $(f).embedded-config.o)
+
+MAINTAINERCLEANFILES = Makefile.in