]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
test/parser: Add pxe discovery tests
[petitboot] / test / parser / Makefile.am
index 47fd458892dabd877451a7c9072e9e66621214a1..b36889df12bdd4301bfb9014784b6984cc994cea 100644 (file)
@@ -39,6 +39,7 @@ TESTS = \
        test-grub2-saved-default \
        test-grub2-nondefault-prefix \
        test-grub2-f18-ppc64 \
+       test-grub2-f20-ppc64 \
        test-grub2-ubuntu-13_04-x86 \
        test-grub2-lexer-error \
        test-grub2-parser-error \
@@ -62,6 +63,17 @@ TESTS = \
        test-pxe-ip-without-conf \
        test-pxe-non-url-conf \
        test-pxe-local \
+       test-pxe-pathprefix-with-conf \
+       test-pxe-non-url-pathprefix-with-conf \
+       test-pxe-pathprefix-discover \
+       test-pxe-pathprefix-discover-mac \
+       test-pxe-path-resolve-relative \
+       test-pxe-path-resolve-absolute \
+       test-pxe-discover-bootfile-root \
+       test-pxe-discover-bootfile-subdir \
+       test-pxe-discover-bootfile-pathprefix \
+       test-pxe-discover-bootfile-relative-conffile \
+       test-pxe-discover-bootfile-absolute-conffile \
        test-unresolved-remove
 
 $(TESTS): %: %.embedded-config.o
@@ -77,6 +89,7 @@ parser_objs = \
        $(top_srcdir)/discover/yaboot-parser.c \
        $(top_srcdir)/discover/kboot-parser.c \
        $(top_srcdir)/discover/pxe-parser.c \
+       $(top_srcdir)/discover/platform.c \
        $(top_srcdir)/discover/resource.c \
        $(top_srcdir)/discover/paths.c \
        $(top_srcdir)/discover/device-handler.c \
@@ -101,6 +114,7 @@ check_PROGRAMS = $(TESTS) libtest.ro
 
 check_DATA = \
        data/grub2-f18-ppc64.conf \
+       data/grub2-f20-ppc.conf \
        data/grub2-ubuntu-13_04-x86.conf \
        data/yaboot-rh8-ppc64.conf