]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
test/parser: Add ubuntu grub tests
[petitboot] / test / parser / Makefile.am
index d8135d4d4756fb82107ad744ed6c26a91118533a..af4fbd673221f4524e494b23e1ea592d996a2a76 100644 (file)
@@ -25,12 +25,20 @@ AM_CPPFLAGS = \
 AM_CFLAGS = -O0 -ggdb -Wall -Wextra -Werror
 
 TESTS = test-null \
+       test-grub2-single \
+       test-grub2-multiple-resolve \
+       test-grub2-f18-ppc64 \
+       test-grub2-ubuntu-13_04-x86 \
+       test-kboot-single \
        test-yaboot-single \
-       test-yaboot-external
+       test-yaboot-external \
+       test-yaboot-rh8-ppc64
 
 check_PROGRAMS = $(TESTS)
 check_LIBRARIES = $(test_libs)
-check_DATA =
+check_DATA = data/grub2-f18-ppc64.conf \
+            data/grub2-ubuntu-13_04-x86.conf \
+            data/yaboot-rh8-ppc64.conf
 
 common_libs = $(top_builddir)/lib/libpbcore.la
 test_libs = libtest.o
@@ -40,6 +48,8 @@ libtest.o: $(libtest_o_OBJECTS)
 
 # objects under test
 parser_test_objs = $(top_srcdir)/discover/yaboot-parser.c \
+                  $(top_srcdir)/discover/kboot-parser.c \
+                  $(top_srcdir)/discover/grub2-parser.c \
                   $(top_srcdir)/discover/resource.c \
                   $(top_srcdir)/discover/paths.c \
                   $(top_srcdir)/discover/device-handler.c \