]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
pb-config: Move config storage modules to "platform" modules in discover code
[petitboot] / test / parser / Makefile.am
index c02fd91ca7984f90db74df2778e042ca874cd3b0..aeb16d8adcab209b05d7f77bf30894f92d627ab7 100644 (file)
@@ -32,14 +32,19 @@ TESTS = \
        test-grub2-default-index \
        test-grub2-default-multiword \
        test-grub2-multiple-resolve \
+       test-grub2-multiple-id \
        test-grub2-single-line-if \
        test-grub2-load-env \
        test-grub2-save-env \
+       test-grub2-saved-default \
+       test-grub2-nondefault-prefix \
        test-grub2-f18-ppc64 \
+       test-grub2-f20-ppc64 \
        test-grub2-ubuntu-13_04-x86 \
        test-grub2-lexer-error \
        test-grub2-parser-error \
        test-kboot-single \
+       test-yaboot-empty \
        test-yaboot-single \
        test-yaboot-partition \
        test-yaboot-partition-override \
@@ -47,6 +52,8 @@ TESTS = \
        test-yaboot-root-global \
        test-yaboot-root-override \
        test-yaboot-device-override \
+       test-yaboot-global-state \
+       test-yaboot-leftovers \
        test-yaboot-default \
        test-yaboot-rh8-ppc64 \
        test-pxe-empty \
@@ -54,7 +61,13 @@ TESTS = \
        test-pxe-initrd-in-append \
        test-pxe-mac-without-conf \
        test-pxe-ip-without-conf \
-       test-pxe-non-url-conf
+       test-pxe-non-url-conf \
+       test-pxe-local \
+       test-pxe-pathprefix-with-conf \
+       test-pxe-non-url-pathprefix-with-conf \
+       test-pxe-pathprefix-discover \
+       test-pxe-pathprefix-discover-mac \
+       test-unresolved-remove
 
 $(TESTS): %: %.embedded-config.o
 $(TESTS): LDADD += $@.embedded-config.o
@@ -69,6 +82,7 @@ parser_objs = \
        $(top_srcdir)/discover/yaboot-parser.c \
        $(top_srcdir)/discover/kboot-parser.c \
        $(top_srcdir)/discover/pxe-parser.c \
+       $(top_srcdir)/discover/platform.c \
        $(top_srcdir)/discover/resource.c \
        $(top_srcdir)/discover/paths.c \
        $(top_srcdir)/discover/device-handler.c \
@@ -93,6 +107,7 @@ check_PROGRAMS = $(TESTS) libtest.ro
 
 check_DATA = \
        data/grub2-f18-ppc64.conf \
+       data/grub2-f20-ppc.conf \
        data/grub2-ubuntu-13_04-x86.conf \
        data/yaboot-rh8-ppc64.conf