]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
pb-config: Move config storage modules to "platform" modules in discover code
[petitboot] / test / parser / Makefile.am
index 8af41905a1007185f4a84d8be69a0691aab00e5f..aeb16d8adcab209b05d7f77bf30894f92d627ab7 100644 (file)
@@ -32,12 +32,14 @@ TESTS = \
        test-grub2-default-index \
        test-grub2-default-multiword \
        test-grub2-multiple-resolve \
+       test-grub2-multiple-id \
        test-grub2-single-line-if \
        test-grub2-load-env \
        test-grub2-save-env \
        test-grub2-saved-default \
        test-grub2-nondefault-prefix \
        test-grub2-f18-ppc64 \
+       test-grub2-f20-ppc64 \
        test-grub2-ubuntu-13_04-x86 \
        test-grub2-lexer-error \
        test-grub2-parser-error \
@@ -51,6 +53,7 @@ TESTS = \
        test-yaboot-root-override \
        test-yaboot-device-override \
        test-yaboot-global-state \
+       test-yaboot-leftovers \
        test-yaboot-default \
        test-yaboot-rh8-ppc64 \
        test-pxe-empty \
@@ -60,6 +63,10 @@ TESTS = \
        test-pxe-ip-without-conf \
        test-pxe-non-url-conf \
        test-pxe-local \
+       test-pxe-pathprefix-with-conf \
+       test-pxe-non-url-pathprefix-with-conf \
+       test-pxe-pathprefix-discover \
+       test-pxe-pathprefix-discover-mac \
        test-unresolved-remove
 
 $(TESTS): %: %.embedded-config.o
@@ -75,6 +82,7 @@ parser_objs = \
        $(top_srcdir)/discover/yaboot-parser.c \
        $(top_srcdir)/discover/kboot-parser.c \
        $(top_srcdir)/discover/pxe-parser.c \
+       $(top_srcdir)/discover/platform.c \
        $(top_srcdir)/discover/resource.c \
        $(top_srcdir)/discover/paths.c \
        $(top_srcdir)/discover/device-handler.c \
@@ -99,6 +107,7 @@ check_PROGRAMS = $(TESTS) libtest.ro
 
 check_DATA = \
        data/grub2-f18-ppc64.conf \
+       data/grub2-f20-ppc.conf \
        data/grub2-ubuntu-13_04-x86.conf \
        data/yaboot-rh8-ppc64.conf