]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
test/parser: add 'partition' directive overriding test for yaboot conf file
[petitboot] / test / parser / Makefile.am
index c2d84a38a84009a0c92cfb7bf98144667cdb0d1f..9029544a4a7d3d7170edd0653864149d9317c22f 100644 (file)
@@ -33,7 +33,13 @@ TESTS = \
        test-grub2-ubuntu-13_04-x86 \
        test-kboot-single \
        test-yaboot-single \
+       test-yaboot-partition \
+       test-yaboot-partition-override \
        test-yaboot-external \
+       test-yaboot-root-global \
+       test-yaboot-root-override \
+       test-yaboot-device-override \
+       test-yaboot-default \
        test-yaboot-rh8-ppc64 \
        test-pxe-single \
        test-pxe-initrd-in-append
@@ -64,7 +70,7 @@ libtest_ro_SOURCES = \
        parser-test.h \
        $(parser_objs)
 
-libtest.ro: $(libtest_ro_OBJECTS)
+libtest.ro$(EXEEXT): $(libtest_ro_OBJECTS)
        $(LD) -o $@ -r $^
 
 check_PROGRAMS = $(TESTS) libtest.ro