]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
test/parser: Remove gawk specifics
[petitboot] / test / parser / Makefile.am
index f711c1e7fab8560c472527b0327ba5df332a6228..84ff2e1906263f4a4294eb4ec9dc778b79b82878 100644 (file)
@@ -26,7 +26,9 @@ AM_CFLAGS = -O0 -ggdb -Wall -Wextra -Werror
 
 TESTS = test-null \
        test-grub2-single \
+       test-grub2-multiple-resolve \
        test-grub2-f18-ppc64 \
+       test-grub2-ubuntu-13_04-x86 \
        test-kboot-single \
        test-yaboot-single \
        test-yaboot-external \
@@ -35,6 +37,7 @@ TESTS = test-null \
 check_PROGRAMS = $(TESTS)
 check_LIBRARIES = $(test_libs)
 check_DATA = data/grub2-f18-ppc64.conf \
+            data/grub2-ubuntu-13_04-x86.conf \
             data/yaboot-rh8-ppc64.conf
 
 common_libs = $(top_builddir)/lib/libpbcore.la
@@ -63,7 +66,7 @@ $(check_PROGRAMS): LDADD += $@.embedded-config.o
 extract_config = $(srcdir)/extract-config.awk
 
 %.embedded-config.c: %.c $(extract_config)
-       gawk --file=$(extract_config) $^ > $@
+       $(AWK) -f $(extract_config) $< > $@
 
 EXTRA_DIST = $(check_DATA) $(extract_config)