]> git.ozlabs.org Git - petitboot/blobdiff - test/parser/Makefile.am
test/parser: Remove gawk specifics
[petitboot] / test / parser / Makefile.am
index af4fbd673221f4524e494b23e1ea592d996a2a76..84ff2e1906263f4a4294eb4ec9dc778b79b82878 100644 (file)
@@ -66,7 +66,7 @@ $(check_PROGRAMS): LDADD += $@.embedded-config.o
 extract_config = $(srcdir)/extract-config.awk
 
 %.embedded-config.c: %.c $(extract_config)
 extract_config = $(srcdir)/extract-config.awk
 
 %.embedded-config.c: %.c $(extract_config)
-       gawk --file=$(extract_config) $^ > $@
+       $(AWK) -f $(extract_config) $< > $@
 
 EXTRA_DIST = $(check_DATA) $(extract_config)
 
 
 EXTRA_DIST = $(check_DATA) $(extract_config)